demo运行不了


#1

Agora Flutter SDK 视频通话应用 继续讨论:

你好,demo运行不了,报错信息:Failed to install E:\flutter_project\Agora-Flutter-Quickstart\build\app\outputs\apk\app.apk: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]


#2

这不是SDK的报错。你用的是真机吗?不支持模拟器的。

build.gradle文件的defaultConfig下增加编译配置试下:

splits {
    abi {
        enable true
        reset()
        include 'x86', 'armeabi-v7a','x86_64'
        universalApk true
    }
}

可以参考一下: INSTALL_FAILED_NO_MATCHING_ABIS 安装包安装失败,返回代码res=-113的解决办法