electron安装SDK,引入import AgoraRtcEngine from "agora-electron-sdk"报错!

控制台报错信息: Failed to compile with 1 errors,This relative module was not found:

  • …/…/build/Release/agora_node_ext in ./node_modules/agora-electron-sdk/js/Api/index.js

1赞

你的electron版本过高了,若electron版本高于3.0.0,可能需要修改.npmrc以切换预编译版本(默认使用1.8.3)

#electron版本(1.8.3,<3.0.0)
AGORA_ELECTRON_DEPENDENT = 2.0.0

#electron版本(>= 3.0.0)
AGORA_ELECTRON_DEPENDENT = 3.0.6

#electron版本(= 4.0.0)
AGORA_ELECTRON_DEPENDENT = 4.0.0

详情请参考:https://github.com/AgoraIO/Electron-SDK/blob/dev/2.8.0/README.zh.md

electron的版本切换成4.0.0的还是同样的问题

这边已经收到你提的工单了,该问题在工单跟进。

您好,我也是这种问题,我用vue-cli-plugin-electron-builder插件进行项目搭建,搭建流程参照这里的地址:https://juejin.im/post/5d1abff7f265da1bb80c47e3。

可以参考:


externals 要配一下。

后来解决了么 我现在也遇到了这样的问题

externals 配置之后确实可以了

1赞

请问 externals 是如何配置的,我配了之后还是报错

你好 externals 配置之后本地 开发没有问题 ,但是打包之后 并没有把SDK 打包进去这个问题如何解决呢?