请问Electron版本的SDK,支持的Electron版本是多少?支持64bit Electron 吗?


我看到文档里说,可以支持>1.8.3,最高支持多少版本?
还有64bit和32bit 的Electron都支持吗?

1.8.3 及以上版本都是支持的,最高支持到最新版。另外,Agora 默认使用 1.8.3 版本的 Electron 进行编译。请根据你的 Electron 版本修改 .npmrc 文件,切换预编译版本:

// 下载使用 Electron 1.8.3 预编译的版本
agora_electron_dependent = 1.8.3
// 下载使用 Electron 3.0.6 预编译的版本
agora_electron_dependent = 3.0.6
// 下载使用 Electron 4.2.8 预编译的版本
agora_electron_dependent = 4.2.8
// 下载使用 Electron 5.0.8 预编译的版本
agora_electron_dependent = 5.0.8

目前只支持 32 bit Electron,使用 Windows 平台进行开发时,需要先运行 npm install -D —arch = ia32 electron 安装 32 位的 Electron。