Unity版本的SDK,打包安卓apk后无法在手机上运行

大佬们,如题,使用Unity版本的SDK,将demo中的例子使用Unity打包为安卓apk后,在手机上安装apk后,一运行就提示如下错误:
Failure to initialize!
Your hardware does not support this application, sorry!

换个手机安装,还是这个错误。这个应该如何解决?

按照readme里的设置里吗,build setting和 plugin里勾选了Android没

这应该是因为 我们 SDK 包的文件夹里有 arm64-v8a ,但是你用 unity 编译时却没有勾选 arm64-v8a。
可以尝试删除 arm64-v8a,或用 unity 编译时勾选 arm64-v8a,再测试一下。

非常感谢。如你所说,删除 arm64-v8a,问题得到解决。

1赞